设为首页 加入收藏 联系我们
客服电话:0551-62613361 传真:0551-62613361
新闻中心   NEWS
您所在的位置:首页 > 新闻中心 > 行业动态
GitHub从本月1日起禁用TLSv1和TLSv1.1来源:开源中国社区 发布日期:2018/2/8

     去年 2 月底的时候,GitHub 曾在 GitHub engineering 博客中宣布,他们将会停止支持弱加密标准。

     加密标准一直都在不断的发展,就像是安全界猫和老鼠的规范游戏 —— 随着新的攻击的出现,旧的标准不能再应对,并推动社区开发更新更强大的标准来代替它们。

     在过去几年,业界发生了许多关于加密攻击的事件,包括但不限于诸如 POODLE 和 Logjam 之类的攻击。虽然对于这些攻击手段都有应对的办法,但这些都体现了被广泛部署的几个加密标准都已进入“英雄迟暮”的阶段,是时候退休了。因此,GitHub 于去年宣布了他们要弃用并最终禁用的加密标准:

TLSv1/TLSv1.1 — 应用于所有的 HTTPS 链接,包括链接到 https://github.comhttps://api.github.com 的 web, API, 和 git

diffie-hellman-group1-sha1 — 应用于所有链接到 github.com 的 SSH

diffie-hellman-group14-sha1 — 应用于所有链接到 github.com 的 SSH

     当时,GitHub 表示所有这些标准都将在 2018 年 2 月 1 日停用 —— 即今天。

     为了最大限度地减少受此更改影响的用户数量,GitHub 在禁用支持之前做了以下的举动:

> 每季度更新一次 GitHub engineering 和 GitHub developer 博客,提醒用户关于弃用这些标准的消息,并鼓励他们为变更做好准备

> 与他们知道的但未和这些变化兼容的热门项目沟通

> 更新自己的 SSH 实现来添加对diffie-hellman-group-exchange-sha256的支持,因为这样可以减少受影响的 SSH 客户端的数量

     希望看到这则消息的开发者和用户能够升级他们的操作系统、库或客户端软件,以便与这些变化兼容。